The requested page cannot be accessed because the related configuration data for the page is invalid

I needed to test a new web site locally before I sent it off to the IT team for further deployment work. I didn’t have IIS installed on my Windows 8 machine, so I installed it and I was happy.

After successfully creating my marvelous site (consisting of a grand total of one ASPX page), I published it via the handy dandy publish window. And off the files went, to my brand new local instance of IIS. And I was greeted with an error page that hated me:

 “The requested page cannot be accessed because the related configuration data for the page is invalid.”

The line in question was:

 <modules runAllManagedModulesForAllRequests="true"/>

Once again, Stack Overflow was my friend. And it turned out, I hadn’t installed ASP.NET. Yes, I could see how that could be a problem. So I ran this command:

C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis -I

Bing bang, it worked. Happiness in Scott land.

Advertisements
  1. Leave a comment

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: